Unable to start the Archive Manager after upgrading to Spectrum 21.2.8
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Unable to start the Archive Manager after upgrading to Spectrum 21.2.8

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Article ID: 239694

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

The following error is seen in the ARCHMGR.OUT file:

Error opening the DDM database. The most likely causes: 

 1. The SQL database server is not running. 
 2. The username, password, hostname, or database name are not correct. 
 3. localhost is not configured properly.

Apr 18 11:21:03 : ArchMgr error opening database.

Environment

Release : 21.2.8

Component : Spectrum Applications

Cause

The $SPECROOT/SS/DDM/.configrc file had the wrong password in the DDM_DATABASE_PASSWORD parameter.

In 21.2.8, we removed the "DDM_DATABASE_PASSWORD=specadmin" parameter from the $SPECROOT/SS/DDM/.configrc file.

If you were to install 21.2.8 from scratch, you would not see this parameter in the .configrc file.

What looks like happened was the upgrade did not remove this entry from the file so the ArchMgr is trying to use the "specadmin"  password for the SPEC_admin user. The default password for the SPEC-admin user is "0n3cl1Ck"

Resolution

Remove the "DDM_DATABASE_PASSWORD=specadmin" parameter from the $SPECROOT/SS/DDM/.configrc file and start the ArchMgr .

Additional Information

This has been fixed in DX NetOps Spectrum 22.2.1:

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/spectrum/22-2/release-information/issues-resolved.html

Symptom: In an upgraded DX NetOps Spectrum environment, DDM_DATABASE_PASSWORD is present in the $SPECROOT\SS\DDM\.configrc file, and Archive Manager is not starting.
Resolution: Code changes are done to ensure that DDM_DATABASE_PASSWORD no longer exists in the $SPECROOT\SS\DDM\.configrc file in an upgraded environment. This eventually facilitates the proper starting of Archive Manager. (DE539388, 33161158, 22.2.1)