APM - Unable to view metric data as a Power user, instead "An error occurred while loading the metric data" is reported.
search cancel

APM - Unable to view metric data as a Power user, instead "An error occurred while loading the metric data" is reported.

book

Article ID: 239380

calendar_today

Updated On:

Products

CA Application Performance Management (APM / Wily / Introscope)

Issue/Introduction

When a local power user (No AD or SAML) logs on to TC and wants to access the  Metric Browser the user is unable to view metric data, instead "An error occurred while loading the metric data" is reported. All the other items in TC are accessible. As a power user, I am also not authorized to the metrics. As a tenant admin, I can see them. 

1/ tenant admin without any universe

https://api-broadcom-ca.wolkenservicedesk.com/attachment/get_attachment_content?uniqueFileId=ZoVscGqM7n53otCcIedl/Q==https://api-broadcom-ca.wolkenservicedesk.com/attachment/get_attachment_content?uniqueFileId=HEjSxcXPCpBWA3CVqtkXdQ==

2/ power user without any universe

https://api-broadcom-ca.wolkenservicedesk.com/attachment/get_attachment_content?uniqueFileId=px37Qala6q7t9/UxfMWTCA==https://api-broadcom-ca.wolkenservicedesk.com/attachment/get_attachment_content?uniqueFileId=8XUHPPhgmFecTrudsd6ZxQ==

 

Environment

Release : 20.2 & 21.3 on-prem

 

Cause

This is because by design the User/Power User with no permission to any Universe, should not see any Agents/Metrics in Metric View. The User with the read permission to a Universe should see Universe configured Agent metrics in Metric View.

Resolution

The User with Edit permission to a Universe can see Universe configured Agent metrics in Metric View. After creating a new test universe and assigning read or write permission to this universe for my power user I am able to see the metrics.

3/ power user with read or write permission to a universe

https://api-broadcom-ca.wolkenservicedesk.com/attachment/get_attachment_content?uniqueFileId=CQKNStM+S4UzSdIBWDW8Og==

https://api-broadcom-ca.wolkenservicedesk.com/attachment/get_attachment_content?uniqueFileId=pFjUg862NVRJ/DtafMV3ew==

https://api-broadcom-ca.wolkenservicedesk.com/attachment/get_attachment_content?uniqueFileId=8dT8mCNoFtUBI2NzM+w/kQ==

Additional Information

AIOPs - Troubleshooting, Common Issues and Best Practices

https://knowledge.broadcom.com/external/article/190815/aiops-troubleshooting-common-issues-and.html