Upgrading the ITMS fails with error: Failed in SetServiceCredential setting 'AltirisSupportService' service to use 'User\ID'. ---> Altiris.NS.Exceptions.AeXException: Failed to OpenService. Error=80070424
search cancel

Upgrading the ITMS fails with error: Failed in SetServiceCredential setting 'AltirisSupportService' service to use 'User\ID'. ---> Altiris.NS.Exceptions.AeXException: Failed to OpenService. Error=80070424

book

Article ID: 239334

calendar_today

Updated On:

Products

Client Management Suite IT Management Suite

Issue/Introduction

Upgrading the ITMS or Configuring it fails with error:

  • ConfigureNS - task_Completed(): Configuration Task Configuring services... Failed: System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> Altiris.NS.Exceptions.SetIdentityException: Failed in SetServiceCredential setting 'AltirisSupportService' service to use 'UserID\Server'. ---> Altiris.NS.Exceptions.AeXException: Failed to OpenService. Error=80070424.

Environment

Release: 8.x

Cause

  • Altiris Services are not running
  • You are not logged in with Service Account/AppID and the Symantec Installation Manager is not running as admin.

Resolution

Make sure any operations involving configure type activities, such as upgrades, reconfigurations, or solution installs are run while logged in as the AppID or service account, and SIM needs to be run with right-click and use the 'Run as administrator" option. 

Attachments