PM OI_connector for saas- cannot load nass records
search cancel

PM OI_connector for saas- cannot load nass records

book

Article ID: 239076

calendar_today

Updated On:

Products

DX Operational Intelligence DX NetOps DX OI SaaS

Issue/Introduction

Checking the OI_connector logs and found it cannot load any NASS records.

[WARN ] [Thread-11] KafkaDAOConsumerThread - [EVENT FAILURE Anonymous:@unknown -> /NetOps OI Connector/com.ca.im.oinet.connector.sources.kafka.dao.KafkaDAOConsumerThread] Encountered exception while processing CAPM Kafka payload - cannot load NASS records._
java.lang.NullPointerException: null
 
but still shows data sent/ingested and no failures
 
CLIENT_SUMMARY_NASS_INGEST_SUCCESS_COUNT: 191891
CLIENT_SUMMARY_NASS_INGEST_FAILED_COUNT: 0
CLIENT_SUMMARY_NASS_INGEST_RETRIED_COUNT: 0
CLIENT_SUMMARY_NASS_REGISTRATION_SUCCESS_COUNT: 0
CLIENT_SUMMARY_NASS_REGISTRATION_FAILED_COUNT: 0


We still get all the metric data as far as we can tell.
We have PM version 21.2.8, OI-SaaS & OI_connector 2.1.6.199

 

Environment

Release : 21.3

Component :

Cause

The NPE is the result of an error handling a situation in the 2.1.6 connector. In the 2.1.7 connector the situation is reported as below

[WARN ]  [Thread-10] KafkaDAOConsumerThread - [EVENT FAILURE Anonymous:@unknown -> /NetOps OI Connector/com.ca.im.oinet.connector.sources.kafka.dao.KafkaDAOConsumerThread] Skipping processing of metric due to null parent device globalid for interface with globalid: <id>

Resolution

The original NPE reported by the 2.1.6 connector is replaced by a more user friendly WARN message in 2.1.7.

Both are indicating that an interface item has not device in Netops portal.
 
If it persists for more than an hour for the same interface item then check in Netops portal why the interface has no device.