Agent Inventory datasource returns failure
search cancel

Agent Inventory datasource returns failure

book

Article ID: 238946

calendar_today

Updated On:

Products

Autosys Workload Automation

Issue/Introduction

Autosys WebUI Agent Inventory does not list all the agents from the scheduler. The DATASOURCES button under Agent Inventory shows an error message
 
Error: WlaInternalServerErrorException: Unexpected exception connecting to Scheduler PRD
Actions: Check the "Web Services URL" and "Monitor User" credentials for the server on the Configuration tab; validate the server
 
 
Server validation under the Configuration tab returns an exception too -
 
  1. Error: E190098 PRD (web services validation) - A connection exception was encountered: https://hostname.company.com:9443/AEWS returned status 403.
 
 
 
CA-wcc.log has the following error captured.
 
INFO | jvm 1 | 2022/04/07 12:27:46 | -194863 | @asi <ForkJoinPool-73296-worker-1> [] ERROR #CAMResponseLoader # Failed request with exception : https://hostname.company.com:9443/AEWS/machine?version=2&filter=createStamp%3C0 , Unexpected exception connecting to Scheduler hostname.company.com 
INFO | jvm 1 | 2022/04/07 12:27:46 | -194863 | @asi <ForkJoinPool-73296-worker-1> [] ERROR #CAMResponseLoader # All requests failed.
INFO | jvm 1 | 2022/04/07 12:27:46 | -194863 | Apr 07, 2022 12:27:46 PM org.owasp.csrfguard.log.JavaLogger log
INFO | jvm 1 | 2022/04/07 12:27:46 | -194863 | INFO: CsrfGuard analyzing request /wcc/quickview/JavaScriptServlet
INFO | jvm 1 | 2022/04/07 12:27:46 | -194863 | @asi <ForkJoinPool-73296-worker-1> [] ERROR #CAMResponseLoader # Failed request with exception : https://hostname.company.com:9443/AEWS/machine?version=1 , Unexpected exception connecting to Scheduler hostname.company.com
INFO | jvm 1 | 2022/04/07 12:27:46 | -194863 | @asi <ForkJoinPool-73296-worker-1> [] ERROR #CAMResponseLoader # All requests failed.
INFO | jvm 1 | 2022/04/07 12:27:46 | -194863 | @asi <ForkJoinPool-73296-worker-1> [] ERROR #SchedulerAgentsDAO # Exception writing Agents to database : Internal error parsing response from Scheduler hostname.company.com
INFO | jvm 1 | 2022/04/07 12:27:46 | -194863 | com.ca.workload.services.exceptions.WlaInternalServerErrorException: Internal error parsing response from Scheduler hostname.company.com
INFO | jvm 1 | 2022/04/07 12:27:46 | -194863 | at com.ca.workload.services.cam.adapters.AEAdapter.getAgents(AEAdapter.java:166)
INFO | jvm 1 | 2022/04/07 12:27:46 | -194863 | at com.ca.workload.services.cam.dao.SchedulerAgentsDAOImpl.retrieveSchedulerAgentsFromScheduler(SchedulerAgentsDAOImpl.java:107)
INFO | jvm 1 | 2022/04/07 12:27:46 | -194863 | at com.ca.workload.services.cam.tasks.RefreshAgents.compute(RefreshAgents.java:54)
INFO | jvm 1 | 2022/04/07 12:27:46 | -194863 | at java.util.concurrent.RecursiveAction.exec(RecursiveAction.java:189)
INFO | jvm 1 | 2022/04/07 12:27:46 | -194863 | at java.util.concurrent.ForkJoinTask.doExec(ForkJoinTask.java:289)
INFO | jvm 1 | 2022/04/07 12:27:46 | -194863 | at java.util.concurrent.ForkJoinPool$WorkQueue.runTask(ForkJoinPool.java:1056)
INFO | jvm 1 | 2022/04/07 12:27:46 | -194863 | at java.util.concurrent.ForkJoinPool.runWorker(ForkJoinPool.java:1692)
INFO | jvm 1 | 2022/04/07 12:27:46 | -194863 | at java.util.concurrent.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:157)
INFO | jvm 1 | 2022/04/07 12:27:46 | -194863 | Caused by: com.ca.workload.services.exceptions.WlaInternalServerErrorException: Unexpected exception connecting to Scheduler hostname.company.com
INFO | jvm 1 | 2022/04/07 12:27:46 | -194863 | at com.ca.workload.services.config.CAMResponseLoader.checkSchedulerHttpResponse(CAMResponseLoader.java:203)
INFO | jvm 1 | 2022/04/07 12:27:46 | -194863 | at com.ca.workload.services.config.CAMResponseLoader.getResponse(CAMResponseLoader.java:135)
INFO | jvm 1 | 2022/04/07 12:27:46 | -194863 | at com.ca.workload.services.cam.adapters.AEAdapter.getAgents(AEAdapter.java:155)
INFO | jvm 1 | 2022/04/07 12:27:46 | -194863 | ... 7 more
INFO | jvm 1 | 2022/04/07 12:27:48 | -194861 | @rest <eem-session-cleanup-WCC0004> [] INFO #SSOContext # session 07041C78A7D5EC8DFE131403CD404769F672B34D79080B196E7A22864D4D902E.hbautoprdwccpr:no activity for 1801 secs
INFO | jvm 1 | 2022/04/07 12:27:48 | -194861 | @rest <eem-session-cleanup-WCC0004> [] INFO #SSOContext # Destroying EEM session. ID=07041C78A7D5EC8DFE131403CD404769F672B34D79080B196E7A22864D4D902E.hbautoprdwccpr reason:SessionInvalidationTask.cleanUpSessions() no activity for 1801 secs
DEBUG | wrapperp | 2022/04/07 12:27:55 | -194855 | Send a packet PING : ping 02719e9d
INFO | jvm 1 | 2022/04/07 12:27:55 | -194855 | WrapperManager Debug: Received a packet PING : ping 02719e9d

 

Environment

Release : 12.0 and higher

Component : Autosys WebUI

Cause

This issue occurred due to missing required privileges for the monitor user being used under the WCC configuration tab.

Resolution

The monitor id needs to be part of the application group: "WorkloadAutomationAEWebService"  in EEM under the WorkloadAtuomationAE application group.

Login to WorkloadAutomationAE in the EEM portal as EiamAdmin.

Search for monitor user id under "Manage Identities" and click on the user.

Under "application groups" click on search and add the "WorkloadAutomationAEWebService" and save.

 

Validate the application server in the Autosys WebUI: 

Logout and login back to WebUI as ejmcommander or any equivalent user with appropriate privileges.

Validate the application server under the configuration tab. It will be validated successfully.

The datasources under agent inventory will also be refreshed with the connection success status. 

All the agents would be listed.

Now the agent count in the inventory tab returns appropriately.

Additional Information

https://techdocs.broadcom.com/us/en/ca-enterprise-software/intelligent-automation/autosys-workload-automation/12-0-01/administrating/ca-wcc-administration/administer-agent-inventory.html