Delta Inventory Scans Running for a Long Time and Failing with Exit code -1002
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Delta Inventory Scans Running for a Long Time and Failing with Exit code -1002

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Article ID: 238914

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Updated On:

Products

Client Management Suite Inventory Solution IT Management Suite

Issue/Introduction

You may notice that your inventory tasks are taking several hours to run, and eventually fail with exit code -1002 when viewed on the SMA agent's task history list.

Environment

Release: 8.6

 

Cause

Corrupted or bad inventory policy.

Resolution

To troubleshoot this issue a little you can do the following on the endpoint:

Under C:\Program Files\Altiris\Altiris Agent\Agents\Inventory Agent\InvTaskConfig you will notice all of your inventory tasks are listed there as XML format.

You can manually run these to see what is happening.  For example, starting from C:\Program Files\Altiris\Altiris Agent\Agents\Inventory Agent open an elevated command prompt.  Run the following command as an example:  C:\Program Files\Altiris\Altiris Agent\Agents\Inventory Agent>InvSoln.exe /i "C:\Program Files\Altiris\Altiris Agent\Agents\Inventory Agent\InvTaskConfig\Collect Delta Software Inventory.xml" /p true

This will show the inventory collection process so that you can observe the behavior.  If there is an issue with collected a particular data class, you should be able to see it in the progress window shown.

The best approach on this would be to stick with the default policies, and check if it meets your inventory needs.  For example the collect full inventory will cover most needs, while the collect delta software inventory policy will fill in the gaps.