search cancel

CVE-2022-22965 & CVE-2022-22963 vulnerability on EEM

book

Article ID: 238868

calendar_today

Updated On:

Products

CA Spectrum CA Application Performance Management (APM / Wily / Introscope) CA Application Performance Management Agent (APM / Wily / Introscope) CA Virtual Assurance for IM CA Service Operations Insight (SOI) CA SM Affiliate Tech Partner Fee CA SM Basic Tech Partner Fee CA SM Prem Tech Partner Fee CA Client Automation - IT Client Manager CA IT Asset Manager CA Service Catalog AutoSys Job Management Adapter for AutoXfer CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation AE - Scheduler (AutoSys) CA Workload Automation AE - System Agent (AutoSys) CA Process Automation Base CA Process Automation Power Pack for Spectrum, IM, and BMC Remedy Process Automation Manager

Issue/Introduction

Product:

EEM 12.6.3 (Common Component)

Issue/Introduction:

Two vulnerabilities CVE-2022-22965 and CVE-2022-22963 have been reported on Spring Framework. 

CVE-2022-22965: Spring Framework RCE via Data Binding on JDK 9+

A Spring MVC or Spring WebFlux application running on JDK 9+ may be vulnerable to remote code execution (RCE) via data binding. The specific exploit requires the application to run on Tomcat as a WAR deployment. If the application is deployed as a Spring Boot executable jar, i.e. the default, it is not vulnerable to the exploit. However, the nature of the vulnerability is more general, and there may be other ways to exploit it.
 

CVE-2022-22963: Remote code execution in Spring Cloud Function by malicious Spring Expression

 In Spring Cloud Function versions 3.1.6, 3.2.2 and older unsupported versions, when using routing functionality it is possible for a user to provide a specially crafted SpEL as a routing-expression that may result in remote code execution and access to local resources.

What is the impact on EEM?

No Impact

 

Environment

All Supported Versions

Resolution

EEM does not use Spring and is not affected by Spring4Shell ZERO-day exploit CVE-2022-22963 and CVE-2022-22965