Web Admin Console Login error when SSL enabled
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Web Admin Console Login error when SSL enabled

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Article ID: 238692

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

DSM Web Console login fails with following error when SSL is enabled

"<%key%>:Unable to connect to Web Service({http://schemas.xmlsoap.org/soap/envelope/}Server.userException)"

Environment

Client Automation 14.5

Cause

This error could occur if SHA Hash is disabled with following registry settings :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Hashes\SHA\Enabled=0

Resolution

- Enable SHA Hash again

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Hashes\SHA\Enabled=0xffffffff

or if SHA hash must remain disabled 
 
Open a CA Broadcom case requesting the fix for cbbj.jar
Then it could be installed with these steps on the Domain Manager with Web Admin Console installed :
 
1- Stop tomcat
caf stop tomcat
 
2- Delete the file C:\Program Files (x86)\CA\DSM\Web Console\webapps\wac\WEB-INF\lib\cbbj.jar
and copy new file cbbj.jar file in this directory
 
3- Start tomcat
caf start tomcat
 
And check that Web Admin Console login is working even if SHA Hash is disabled.

Additional Information

Remark :

The updated cbbj.jar file is part of patch CU3, CU4 (and next CU patches).