Translation is not applied as expected
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Translation is not applied as expected

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Article ID: 238685

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

A translation using the Localization (Beta) feature is not displayed as expected or as it appears in the translation files.

Environment

Release : Any supported Clarity release.

Component : Clarity MUX Blueprints and Administration

Cause

The translations would be coming to the browser as "files" from the server. The files are built from the translations stored in the database if you have modified them. When the files are retrieved, they are cached in the browser and there is an expiration date on them. This is done so we don't download them again and again when they are requested as the user navigates from page to page.

Resolution

Option 1) Bypass the cache for that page ('Hard reload'): https://en.wikipedia.org/wiki/Wikipedia:Bypass_your_cache#Desktop_browsers

Additional method for Chrome and Edge:

  1. Open the Developer Tools (browser menu > More Tools > Developer Tools)
  2. With the Developer Tools still open, right-click on the browser refresh icon and select the Hard Reload option.

 

Option 2) Clear the browser caches: https://en.wikipedia.org/wiki/Wikipedia:Bypass_your_cache#Cache_clearing_and_disabling

Additional browser vendor documentation on how to clear caches:

Note that some browsers may allow clearing the caches for a certain amount of time. In this case, it is always recommended to select "Everything", "All time" or the equivalent option.

Additional Information

CA PPM Tuesday Tip: How to ensure data is displayed properly in the browser