Broadcom API Gateway - JDBC Connections hangs in "testing"
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Broadcom API Gateway - JDBC Connections hangs in "testing"

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Article ID: 238684

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Updated On:

Products

CA API Gateway

Issue/Introduction

Customers have reported an issue with the TEST function in the Manage JDBC Connection configuration window.

Under specific conditions, the TEST operation hangs in "Testing" for a long time and even when the CANCEL button is pressed, the connection will remain in a busy state.

 

Environment

Release : 10.1

Component : API GATEWAY

Cause

The issue is caused by the underlying c3p0 connection not timing out in a reasonable time period for cases where connectivity between Gateway and the remote Database are affected by an ongoing issue (for example a Firewall rule not allowing full communication between the two parties).

Resolution

Solution is to enforce a timeout via c3p0.checkoutTimeout property.

  • Open Manage JDBC Connection in Policy Manager and edit the affected JDBC connection.
  • In the configuration window, click on ADD (1) button in the Additional Properties 
  • Set a new property (2) with the following values:

Property Name (case sensitive): checkoutTimeout
Property Value (milliseconds): 5000

  • The new property should show in the list as shown in the screenshot below (3)

 

Additional Information

c3p0.checkoutTimeout reference: https://www.mchange.com/projects/c3p0/#checkoutTimeout