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Registry going down frequently - Qualys scanner problem and Reg to ED communication problem - Network Latency issue.

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Article ID: 238640

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Updated On:

Products

Service Virtualization

Issue/Introduction

Hi Team,

We are having troubles with Registry going down frequently. We see couple of errors and timeout in registry.log file.

I have attached them to the case along with vse.log file

Please let me know if you need any other details for further investigation.

Cause

Reg to ED communication problem

 "patch_DE530248_10.6.0_GA.jar" increases the timeout for Registry to ED communication from default 10 seconds to 30 seconds.

 

Environment

Release : 10.6

Component : DevTest Application Test

Resolution

Please open a support ticket and request patch_DE530248_10.6.0_GA.jar and other dependent patches. 

 

Steps to apply:

 

NOTE: The patch is needed only on Registry machine

 

1. Stop all Devtest Services

2. Place the patch file "patch_DE530248_10.6.0_GA.jar" at LISA_HOME\lib\patches folder

3. Edit LISA_HOME\logging.properties; add the following entries and save the file:

 

log4j.logger.com.itko.lisa.dradis.rest.client.DradisRestClient=DEBUG
log4j.logger.com.itko.lisa.dradis.comm.DradisRestStrategy=DEBUG

 

4. Restart all Devtest Services that were stopped in Step #1

 

For maximum protection of Registry process against Qualys Scanner,  please follow the KB article below: 

https://ca-broadcomcsm.wolkenservicedesk.com/wolken/esd/knowledgebase_search?articleId=228075