When requesting a user object via the API, not all attributes are shown
search cancel

When requesting a user object via the API, not all attributes are shown

book

Article ID: 238637

calendar_today

Updated On:

Products

Rally SaaS Rally On-Premise Rally Perpetual Hosted

Issue/Introduction

When requesting a user object via WSAPI, not all of the user object attributes are visible.

For example, the following request is missing numerous fields such as DefaultProject, EmailNotificationEnabled, LastActiveDate and many more:

 

Cause

For security reasons, this can happen when the user making the request does not have sufficient access levels to view these privileged fields.

Resolution

Make the request using a user ID with higher security permissions.  At a minimum, Workspace Administrator permissions are needed to view these additional fields.