ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

Impact of CVE-2022-22965: SpringShell on Advanced Authentication

book

Article ID: 238608

calendar_today

Updated On:

Products

CA Strong Authentication CA Risk Authentication CA Advanced Authentication

Issue/Introduction

We are using below product and would like to understand the impact of CVE-2022-22965: SpringShell 

Strong Authentication (Arcot) - 9 .1 

I am following the below advisory link.

https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/20427.

Environment

Release : 9.1

Component : Strong Authentication

Risk Authentication

Resolution

CVE-2022-22965 Detail:

A Spring MVC or Spring WebFlux application running on JDK 9+ may be vulnerable to remote code execution (RCE) via data binding. The specific exploit requires the application to run on Tomcat as a WAR deployment. If the application is deployed as a Spring Boot executable jar, i.e. the default, it is not vulnerable to the exploit. However, the nature of the vulnerability is more general, and there may be other ways to exploit it.

These are the prerequisites for the exploit:

  • JDK 9 or higher
  • Apache Tomcat as the Servlet container
  • Packaged as WAR
  • spring-webmvc or spring-webflux dependency.

Advanced Authentication Impact : 

Advanced Authentication product does not support JDK 9+ version and it only supports JDK/JRE 8.x so we are not impacted by this vulnerability.

Additional Information

Spring Framework RCE Early Announcement

Symantec Security Advisory for Spring Framework CVE-2022-22965