REST server not working for Service Desk Manager
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REST server not working for Service Desk Manager

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Article ID: 238529

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Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

REST API not working on Service Desk Manager 17.3.  Users may experience an error such as:

"The origin server did not find a current representation for the target resource or is not willing to disclose that one exists."

Postman shows: HTTP Status 404 - Not Found

Environment

Release : 17.3

Component :  CA Service Desk Manager REST Web Services

Cause

Discovered that caisd-rest.war was missing from Service Desk Manager\bopcfg\www\CATALINA_BASE_REST\webapps - it was suspected that it had been deleted by accident.

Resolution

To repair it, copy caisd-rest.war.bck from Service Desk Manager\site\rest to the Service Desk Manager\bopcfg\www\CATALINA_BASE_REST\webapps folder, rename it to caisd-rest.war, then run:

pdm_tomcat_nxd -c stop -t REST

pdm_tomcat_nxd -c start -t REST

to redeploy.

After this, the REST application calls are working again.

Additional Information

Above may also be effective if one can only access the given REST Services via hostname but not by IP address