“No snapshot found” when trying to view an Identity Manager report after a database change
search cancel

“No snapshot found” when trying to view an Identity Manager report after a database change

book

Article ID: 238402

calendar_today

Updated On:

Products

CA Identity Suite CA Identity Manager CA Identity Portal

Issue/Introduction

Created a new database to be used with IM Snapshots:

1. A new database was created with the relevant script for schema/table creation

2. Changed the database connection paraneters for snapshot database in the IM via task “Modify Snapshot Database Connection: rptParamConn”

3. Updated the database connection URL in standalone-full.xml in the application server

4. Captured a snapshot and the data is correctly stored in the new database.

When attempting to view a report, however, the following error is observed: “No snapshot found”

Environment

Release : 14.x

Component : IdentityMinder(Identity Manager)

Cause

When an Identity Manager environment (IME) is created (from the management console), it populates the data of all available OOTB snapshots in [imrptsnapshots12] table.

When we create a new DB, while the table is created as part of the schema, it has no information about existing environments and snapshot definitions. If we create the environment after the new DB has been assigned, it will then populate the relevant [imrptsnapshots12] table with the snapshot data.

Resolution

 Ensure to copy the data from the original database [imrptsnapshots12] table into the new database [imrptsnapshots12] table - with this step done, the new database can be used by the report server.