ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

CAPKI Installer not working for AIX 64-bit

book

Article ID: 238398

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Our server admin found that the CAPKI installer (setup) for version 5.2.8. is not working for AIX x64.

 

The problem is that the setup file is somehow corrupted and AIX does not recognize it as executable binary file.

[email protected]:/automic/uc4/capki/CA.PKI/unix/aix/powerpc64#./setup discover
-bash: ./setup: cannot execute binary file

[email protected]:/automic/uc4/capki/CA.PKI/unix/aix/powerpc64#file setup
setup: data or International Language text

[email protected]:/automic/uc4/capki/CA.PKI/unix/aix/powerpc64#ldd ./setup
ldd: ./setup: File is not an executable XCOFF file.

 

Cause

This is a defect

Environment

Component : CAPKI v5.2.8

Resolution

The 64-bit CAPKI installer doesn't work on AIX. This will be fixed in a future version.