search cancel

Error while installing Broadcom TDM v4.10

book

Article ID: 238370

calendar_today

Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

We are facing error while installing Broadcom TDM v4.10 in Windows 2019 server. 

We followed the steps given in the link(https://techdocs.broadcom.com/us/en/ca-enterprise-software/devops/test-data-management/4-10/installing/upgrade-product-components.html to install Broadcom TDM v4.10, but we are getting the below error.

 

ERROR:

    "disk1.cab has an invalid digital signature. This may indicate that cabinet file is corrupted"

 

 

Cause

Problem was caused by the root certificate 'USERTrust RSA Certification Authority' on the customer's windows machine being set as issued by 'AAA Certificate Services'. On a working machine the same root certificate 'USERTrust RSA Certification Authority' was correctly set as issued by 'USERTrust RSA Certification Authority'.

When trying to install authentication was failing due to the incorrect certificate. Somehow the OS keeps retriving the wrong certificate.

Environment

Release :  TDM 4.10

Component :  GTServcer

Resolution

Get a copy of the correct certificate from a working system and import it to the problem system in 'Trusted Root Certification Authorities' and remove the wrong certificate.