ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

APM no longer sends emails after a few days, requiring constant restarts of MOM

book

Article ID: 238202

calendar_today

Updated On:

Products

CA Application Performance Management (APM / Wily / Introscope)

Issue/Introduction

The last time emails worked was on 3/28/2022 around 11:50pm EST.

Today Mar 30th, 2022- no emails.

MOM was restarted now to receive the Alert Emails. 

EM debug and Thread dumps were collected for analysis. 

Cause

Per thread dump - caused by a FieldPAck

can see all 5 Alert Action threads are stuck on getting response from the Server.

i.e.

"Alarm Pooled Worker" #109440 daemon prio=5 os_prio=0 tid=0x00007f9f5803c800 nid=0xcd92 runnable [0x00007f9e43872000]
   java.lang.Thread.State: RUNNABLE

   at com.wily.field.custom.alertaction.SpecialSendSMTPMailAction.sendEmail(SpecialSendSMTPMailAction.java:84)

 

It is from a field pack.

 

Environment

Release : 10.7.0

Component :

Resolution

Engineering has provided an updated FieldPack (DE532681)