Incident Persister service will not start after upgrade to DLP 15.8
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Incident Persister service will not start after upgrade to DLP 15.8

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Article ID: 238076

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Updated On:

Products

Data Loss Prevention Data Loss Prevention Enforce

Issue/Introduction

After upgrading to DLP 15.8, the Incident Persister service will not start.

The tomcat log has this entry;

[com.vontu.incidenthandler.IncidentPersister.start] Unexpected error starting Incident Persister.
org.springframework.boot.web.embedded.tomcat.ConnectorStartFailedException: Connector configured to listen on port 9000 failed to start

Environment

Release: 15.8

 

Cause

In 15.8 the Incident Persister added some new spring boot features that, by default, included an embedded tomcat service which was bound to port 9000.
Because another application already was bound to port 9000 the Incident Persister couldn't start.

Resolution

Workaround:

  1. Open the SymantecDLPIncidentPersister.conf file located at
    • Windows:  \Program Files\Symantec\DataLossPrevention\EnforceServer\Services
    • Linux: /opt/Symantec/DataLossPrevention/EnforceServer/Services
  2. Append the following line to the end of that file (change 9001 to the port they want)
    • wrapper.java.additional.210 = -Dserver.port=9001
  3. Restart the Incident Persister and note that it will now bind the Incident Persister's Tomcat service to the new port

 

Another possible resolution is to reboot the server to clear any hung sessions on port 9000.
Running "netstat -anb" from the command prompt may show sessions on port 9000.
However, no service is listening on this port as the Incident Persister will not start.