ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

Spectrum Webtomcat crashed and the process needed to be killed to resume.

book

Article ID: 237745

calendar_today

Updated On:

Products

CA Spectrum

Issue/Introduction

Spectrum Webtomcat crashed and the process needed to be killed to resume.

webswing.log shows

Exception in thread "https-jsse-nio-9443-exec-158" 20-Mar-2022 04:24:38.178 SEVERE [https-jsse-nio-9443-exec-196] org.apache.coyote.AbstractProtocol$ConnectionHandler.process Failed to complete processing of a request
 java.lang.OutOfMemoryError: Java heap space
Exception in thread "https-jsse-nio-9443-exec-208" Exception in thread "https-jsse-nio-9443-exec-176" Exception in thread "https-jsse-nio-9443-exec-190" Exception in thread "https-jsse-nio-9443-exec-204" 20-Mar-2022 04:25:25.821 SEVERE [https-jsse-nio-9443-exec-199] org.apache.coyote.AbstractProtocol$ConnectionHandler.process Failed to complete processing of a request
 java.lang.OutOfMemoryError: Java heap space
java.lang.OutOfMemoryError: Java heap space
java.lang.OutOfMemoryError: Java heap space
java.lang.OutOfMemoryError: Java heap space

Cause

The webswing team have build a new Webswing version 20.2.17 for this problem.

Environment

Release : 21.2

Component : Spectrum OneClick

Resolution

The webSwing team has provided the latest webSwing war files which resolves this known issue.

admin.war
spectrum.war

these contain the latest webswing version 20.2.10 which will replace the current one on your system

1. Stop Webtomcat service.

2. Go to $SPECROOT/webtomcat/webapps directory and move the existing spectrum.war and spectrum folder plus the admin.war and admin folders to another directory as backup.

3. Put the uploaded new spectrum.war file and admin.war in $SPECROOT/webtomcat/webapps 

4. Start Webtomcat service.

5. Now it should extract the spectrum.war file to spectrum folder. Please cross verify this once.

6. test both the webapp and the webapp management console are accessible.

7. reproduce issue