search cancel

.NET Framework Requirement for UIM

book

Article ID: 237713

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

What is the requirement of the use of .NET with UIM?

We have .NET versions 3.5 and 4.5 and these have been classed as Sev 5 vulnerability.

Cause

Legacy dependencies on the use of IM

Environment

Release : 20.x

Component : UNIFIED INFRASTRUCTURE MGMT

Resolution

UIM itself does not require .NET to run.

However, the Infrastructure Manager, legacy client, needs .NET 3.5 (version required) to render some of the probe GUIs (not all - only some). 

So you must run the .NET 3.5 or .NET 4.0 or 4.5 only on the system where IM is running, to be able to render some of the probes.

 

Examples of some of these monitoring probes:

vmax probe dot net framework error (broadcom.com)

ad_server (Active Directory Server Monitoring) Release Notes (broadcom.com)

rhev (Red Hat Enterprise Virtualization) Release Notes (broadcom.com)

ibmvm (IBM Virtualization Monitoring) Release Notes (broadcom.com)

 

But not service/architecture basic probes. 

 

Summarizing .NET is not a requirement for UIM (or for a secondary hub) to run, but only for sytem running the IM client to render some of the .NET probes that have this dependency. 

Additional Information

•  Engineering is working on a feature F122180 (internal reference) to Upgrade .Net Framework version for all probes to v4.8. We don't have an ETA yet. 

•   Attached to this KB is HOTFIXED ad_server 2.03 package t2 build that works without the dependency on .NET 3.5 

Attachments

1650881109369__ad_server-2.03-T2.zip get_app