ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

Issue with UIM 20.4UC1 oc_cumulative_update-20.4.1.zip with error: "Dependency check error"

book

Article ID: 237577

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

After upgrading to UIM 20.4UC1 and deploying the oc_cumulative_update-20.4.1

The console and log show the following: 

Distribution to YZSolutions/yx12prod_hub/yx12ump of oc_cumulative_update (20.41): Unable to resolve dependency to ump_dashboard (-2) job=system-5 (Created by: administrator on dxprod)

Log:

Distribution to /YZSolutions/yx12prod_hub/yx12ump of oc_cumulative_update (20.41): Unable to resolve dependency to ump_dashboard (-2) job=system-5 (Created by: administrator on yx12prod) distsrv: Setting security for probes in section generic
distsrv: hub address = /xxxyyyyyy12s/xyprod_hub/yx12prod/hub
distsrv: Unable to remove file D:\nimsoft/archive/temp_i1\files\qos_watcher\Common\qos_watcher.pl, errno = 13
distsrv: Unable to remove directory D:\nimsoft/archive/temp_i1\files\qos_watcher\Common, errno = 41
distsrv: Unable to remove directory D:\nimsoft/archive/temp_i1\files\qos_watcher, errno = 41
distsrv: Unable to remove directory D:\nimsoft/archive/temp_i1\files, errno = 41
distsrv: Unable to remove directory D:\nimsoft/archive/temp_i1, errno = 41
distsrv: inst_done: Error: failed: OK
distsrv: license_check from 1xx.1xx.1x.2x/80
distsrv: Dependency check error: Unable to find any version of package mcsuiapp_portlet on /YZSolutions/yx12prod_hub/yx12ump
distsrv: is_package_there: metapack_helper / 20.41 ?
distsrv: Dependency check error: Unable to find any version of package metapack_helper on /YZSolutions/yx12prod_hub/yx12ump
distsrv: is_package_there: mcsuiapp_portlet / 20.41 ?
distsrv: Dependency check error: Unable to find any version of package mcsuiapp_portlet on YZSolutions/yx12prod_hub/yx12ump

distsrv: is_package_there: ump_dashboard / 20.41 ?
distsrv: Dependency check error: ump_dashboard version = 20.41 is required (20.40 found)
distsrv: is_package_there: wasp_alarmviewer_api / 20.41 ?
distsrv: Dependency check error: wasp_alarmviewer_api version = 20.41 is required (20.40 found)
distsrv: is_package_there: policy_management_ws / 20.41 ?
distsrv: Dependency check error: policy_management_ws version = 20.41 is required (0.22 found)
distsrv: is_package_there: uim_reportscheduler / 20.41 ?
distsrv: Dependency check error: uim_reportscheduler version = 20.41 is required (20.40 found)
distsrv: is_package_there: ump_operatorconsole / 20.41 ?
distsrv: Dependency check error: ump_operatorconsole version = 20.41 is required (20.40 found)
distsrv: is_package_there: ump_slm / 20.41 ?
distsrv: Dependency check error: ump_slm version = 20.41 is required (20.40 found)

Cause

Dependency check error: Unable to find any version of package mcsuiapp_portlet on /BPSolutions/dxprod_hub/dxump

Environment

Release:  UIM 20.4UC1

Component : oc_cumulative

Resolution

Steps to follow:

1. Using oc_cumulative_update (Using Admin console)

or 

2. Manually deploying the packages as suggested. 

Deactivate wasp and drag the following to OC  robot:
- mcsuiapp_portlet 20.41
- policy_management_ws 20.41
- uim_reportscheduler 20.41
- ump_dashboard 20.41
- ump_operatorconsole 20.41
- ump_slm 20.41
- wasp_alarmviewer_api 20.41
Activate wasp and give it a try

Additional Information

The "oc_cumulative_update" is not supported in IM, but it is supported in Admin Console.