MCS profiles are not being installed to a robot - (80) Session error, Unable to open a client session
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MCS profiles are not being installed to a robot - (80) Session error, Unable to open a client session

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Article ID: 237558

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

MCS group profiles were initially deployed to a robot a few weeks back but profiles show an Hourglass when viewing the Monitoring Config status on the device itself

 

Are there any steps I can take to see what is causing the problem with deployment problem?

Environment

Release : 20.4, 20.3

Component : UIM OPERATOR CONSOLE - MCS UI

Cause

Communication issue with the robot 

Resolution

1. Launched OC -> Dashboard -> Deployment Dashboard

2. Select View By Devices and filtered by device name using suspect robot name

3. In this example, all profiles status showed the following error with timestamp: 2/23/22 7:00 PM
Deployment deferred awaiting probe deployment or redeployment: (80) Session error, Unable to open a client session for robotipaddress:48000: Connection timed out: connect

4a. Launch IM, select the controller probe for suspect robot, used Ctrl+P to launch the probe utility, clicked on the Option button and copy the Nimbus address

4b. In IM, selected the hub probe on the UIM server, used Ctrl+P to launch the probe utility, clicked on the Probe commandset pull down menu, select nametoip and enter suspect robot's "Nimbus address" in the name field, executed the command set and validate that the correct IP is returned for the robot

4c. Repeat step 4b from the hub that the robot belongs to and validate that correct IP is returned

Step 4b and 4c confirmed that the UIM Server and Secondary hub do not have communication issues with suspect robot. Communication issues may have been present before but since then have cleared up.

Steps to re-deploy the MCS profiles

5. Run a mon_config_service plugin_metric_correction against suspect robot and validate if all deployment issue is resolved for all profiles.

If some profiles still show the errors, got to Step 6.

6. Restart the nimbus service on suspect robot and run the mon_config_service plugin_metric_correction again

7. If Step 6 does not resolve the issue, run the following query to obtain obtain a list of all profiles and cs_id for suspect robot

select
(select top(1) objectvalue from SSRV2AuditTrail where objecttype = 'profile' and objectid = dp.profileId order by timestamp desc) as reason, 
d.name as device_name, 
d.status as device_status,
r.address as robot_address, 
r.robot_active,
r.status as robot_status, 
dp.status,
dp.*
from SSRV2Profile dp
join ssrv2device d on d.cs_id = dp.cs_id
join cm_device cd on cd.cs_id = dp.cs_id
join cm_nimbus_robot r on r.dev_id = cd.dev_id
where dp.cs_id is not null
and d.name like '%suspect robot name%'

7a. Execute the following query against suspect robot's cs_id and this should redeploy the profiles

update ssrv2profile set status = 'new' where cs_id 12345