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Error repeating many times in CA-App logs PPM_REST_API AuthenticationFilter ::  Exception while authentication user.

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Article ID: 237505

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

We are seeing the same error message again and again in the ca-app logs on our web application servers in production. 

ERROR 2022-02-01 22:09:38,944 [https-jsse-nio2-8443-exec-6] ppm.rest (clarity:unknown:37067599__4185EF58-2ECD-41EB-9209-C6267154D911:PPM_REST_API) AuthenticationFilter ::  Exception while authentication user.
com.niku.union.security.SecurityException: Authentication Failure Error!
 at com.ca.ppm.rest.security.AuthenticationFilter.doFilter(AuthenticationFilter.java:89)
 at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:193)
....

Cause

This has been seen in On Premise Load Balanced Clarity environments.

Some Load Balancers may not be using Session Persistence.

Environment

Release : 15.8.1

Component : 

Resolution

Speak with your Load Balancer administrator about using session persistence so that the user is sent to the same Clarity app server for every request.

Additional Information

F5 Load Balancer timeout recommendations for Clarity