After upgrade can not connect Data maker to Repository

book

Article ID: 237482

calendar_today

Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

We upgraded the TDM Portal and datamaker to 4.10.
After the upgrade, the portal is working.
However, when we try to connect to the gtrep database server on MS SQL server 2016 we get an error about the client not being able to use SSL encryption.
How do we correct this?

Cause

The gtrep SQL server was upgraded to enable SSL for all connections.

Environment

TDM Datamaker 4.10
MS SQL 2016

Resolution

Both TDM datamaker 4.9.1.X and 4.10.X have had a patch provided to update the MS SQL server driver to version 18 which will allow for the connection to new database servers including those set up with encryption.
The drivers are part of the 4.9.1040 and 4.10.2 datamaker patches.
Below is the link to the TDM Patches page.
Test-Data-Manager-TDM-Patches

The new drivers will be in the following location.
c:\program Files (x86)\Grid-tools\GTDatamaker\GTFiles| MSSQL Server ODBC Client 18.0


You will need to run this installation manually.

Next, go out to MS website and download the following and install it:
https://www.microsoft.com/en-eg/download/details.aspx?id=56730


Then go into the 32-bit ODBC connection and create a new connection to the GTREP database using the SQL Server 18 driver to make the connection.
Last you will need to update Datamaker to use the new 32-bit ODBC connection name.

 

Attachments