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xendesktop probe is getting Null values

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Article ID: 237416

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

We are receiving value as a null for the xendesktop machines for the CPU, Memory metrics

QOS_XENDESKTOP_DESKTOP_CPU
QOS_XENDESKTOP_DESKTOP_MEMORY

Logs show the following message:

 Access was denied:

Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

Cause

Permissions were not correctly set to allow the service account to use the WMI commands.

Environment

Release : 20.3

Component : UIM - XENDESKTOP

Resolution

Customer followed added permissions for the service account to use WMI and run these commands.

https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2008-R2-and-2008/cc771551(v=ws.11)