IMPS failed to start after applying 14.4 CP patch
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IMPS failed to start after applying 14.4 CP patch

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Article ID: 237397

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Updated On:

Products

CA Identity Manager CA Identity Suite

Issue/Introduction

After applying 14.4 CP patch (overwrite the bin and data folders), provisioning server does not start up properly.  The im_ps.log file shows:

im_ps.log:
[06:52:49.635:00000DE8] loaded module eTrustAdminServer.dll
[06:52:49.635:00000DE8] module eTrustAdminServer.dll: null module registered
[06:52:49.635:00000DE8] line 112 (database          etrustadmin)
[06:52:49.635:00000DE8] database etrustadmin initialization failed.
[06:52:49.651:00000DE8] slapd stopped.
[06:52:49.651:00000DE8] connections_destroy: nothing to destroy.

In event viewer, the following error appear

The Symantec Identity Manager - Provisioning Server service terminated with the following service-specific error: 
The media is write protected.

Environment

Release : 14.4

Component : Identity Manager

Cause

This is due to the updated ETPKI files distributed with the CP not having been applied.

Resolution

 

Make sure to apply IMPD CP prior IMPS CP and also apply ETPKI CP patch.

Try checking the HKLM\SOFTWARE\WOW6432Node\ComputerAssociates\Shared\CAPKI5 registry key which should point to the location of the ETPKI installation in the InstallDir string value. In my machine this points to "C:\Program Files (x86)\CA\SharedComponents\ETPKI\CAPKI".

You would then go to whatever location your registry points to and under that folder you should see the "\CAPKI5\Windows\x86\32\lib" folder structure which is where you need to update the 5 ETPKI related DLL files with what you are provided with as part of the CP package.