ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

Seeing log4j-1.2.17-cloudera1.jar files on the DX Netops Portal

book

Article ID: 237381

calendar_today

Updated On:

Products

CA Performance Management - Usage and Administration

Issue/Introduction

Seeing the following files on the DX Netops Portal:


/opt/CA/PerformanceCenter/DM/webapps/dm/WEB-INF/lib/log4j-1.2.17-cloudera1.jar 
/opt/CA/PerformanceCenter/EM/webapps/EventManager/WEB-INF/lib/log4j-1.2.17-cloudera1.jar
/opt/CA/PerformanceCenter/PC/webapps/pc/WEB-INF/lib/log4j-1.2.17-cloudera1.jar

Cause

User Story: US809029

These files are needed for the CA Business Intelligence integration with DX Netops Performance Management

Environment

Release : 21.2

Component : PM Web UI Admininistration/Configuration

Resolution

The files are updated to log4j 2.17.2 in DX Netops Performance Management 21.2.10.

 

 

Additional Information


WORKAROUND for versions < 21.2.10, If you are not using CABI the files can be removed.


1) Back up the files:

a) cd to the PCINSTALLDIR/PerformanceCenter directory

b) Back up the files
 

tar zcvf /tmp/cabijars.tar.gz DM/webapps/dm/WEB-INF/lib/cabi-jasperreportsserver-commonutil-6.4.2.jar \
EM/webapps/EventManager/WEB-INF/lib/cabi-jasperreportsserver-commonutil-6.4.2.jar \
PC/webapps/pc/WEB-INF/lib/cabi-jasperreportsserver-commonutil-6.4.2.jar \
DM/webapps/dm/WEB-INF/lib/cabi-jasperreportsserver-sso-6.4.2.jar \
EM/webapps/EventManager/WEB-INF/lib/cabi-jasperreportsserver-sso-6.4.2.jar \
PC/webapps/pc/WEB-INF/lib/cabi-jasperreportsserver-sso-6.4.2.jar \
DM/webapps/dm/WEB-INF/lib/log4j-1.2.17-cloudera1.jar \
EM/webapps/EventManager/WEB-INF/lib/log4j-1.2.17-cloudera1.jar \
PC/webapps/pc/WEB-INF/lib/log4j-1.2.17-cloudera1.jar

Copy/move the /tmp/cabijars.tar.gz file to a safe location.

2) Remove the files, make sure to verify each file during the delete:

a) cd to the PCINSTALLDIR/PerformanceCenter directory

b) Remove the files:

rm -i DM/webapps/dm/WEB-INF/lib/cabi-jasperreportsserver-commonutil-6.4.2.jar \
EM/webapps/EventManager/WEB-INF/lib/cabi-jasperreportsserver-commonutil-6.4.2.jar \
PC/webapps/pc/WEB-INF/lib/cabi-jasperreportsserver-commonutil-6.4.2.jar \
DM/webapps/dm/WEB-INF/lib/cabi-jasperreportsserver-sso-6.4.2.jar \
EM/webapps/EventManager/WEB-INF/lib/cabi-jasperreportsserver-sso-6.4.2.jar \
PC/webapps/pc/WEB-INF/lib/cabi-jasperreportsserver-sso-6.4.2.jar \
DM/webapps/dm/WEB-INF/lib/log4j-1.2.17-cloudera1.jar \
EM/webapps/EventManager/WEB-INF/lib/log4j-1.2.17-cloudera1.jar \
PC/webapps/pc/WEB-INF/lib/log4j-1.2.17-cloudera1.jar


3) Restart the DX Netops Portal services:

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/performance-management/21-2/administrating/restart-ca-performance-management-component-services/restart-performance-center.html

4) If you need to restore the files:

a) Copy the cabijars.tar.gz to the PCINSTALLDIR/PerformanceCenter directory

b) Extract the files:

tar zxvf cabijars.tar.gz

c) Restart the DX Netops Portal services:

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/performance-management/21-2/administrating/restart-ca-performance-management-component-services/restart-performance-center.html