Error: Redirect - 404 Error Page when trying to connect to the Symantec DLP Enforce Console
search cancel

Error: Redirect - 404 Error Page when trying to connect to the Symantec DLP Enforce Console

book

Article ID: 237322

calendar_today

Updated On:

Products

Data Loss Prevention Data Loss Prevention Enforce Data Loss Prevention Oracle Standard Edition 2

Issue/Introduction

 

The "Redirect - 404 Error Page" messages appears when trying to navigate to the Symantec DLP Enforce Console logon page. 

IncidentPersister logs show:

[com.vontu.util.jdbc.JDBCTestConnection.testDatabaseConnectionAndCheckSchemaVersion] Cannot connect to database
java.sql.SQLRecoverableException: IO Error: The Network Adapter could not establish the connection


Localhost logs show:

WARNING [com.vontu.util.jdbc.JDBCTestConnection] Cannot connect to database
Cause:
java.sql.SQLRecoverableException: IO Error: The Network Adapter could not establish the connectionjava.sql.SQLRecoverableException: IO Error: The Network Adapter could not establish the connection


If we try to connect to the protect database via sqlplus, the following error is returned:

sqlplus protect@protect
ORA-12505, TNS:listener does not currently know of SID given in connect descriptor


The SERVICE_NAME connection information in tnsnames.ora, listener.ora on the database server/Oracle client and the Jdbc.properties file on the Enforce server, match and are correct.


The System Environment Variable ORACLE_HOME on both the Enforce and database servers show the correct path.
The System Environment Variable PATH on both the Enforce and database servers show %ORACLE_HOME%\bin is listed first.


On the database server, run 'lsnrctl services' in command line. The protect service is not listed.

Connecting to the database as the sys user, we see the message that we're connected to an idle instance.

SQL> connect sys as sysdba
Connected to an idle instance


If you try to run any commands in sqlplus as the sys user, the following error appears:

Error at line 1.
ORA-01034: ORACLE not available
Process ID: 0
Session ID: 0 Serial number: 0


Running the database startup command returns an access denied error:

sqlplus /nolog
conn sys as sysdba
startup

ORA-48173: error checking directory existence during ADR initialization [c:\ORACLE\diagdbms\protect]
ORA-48187: specified directory does not exist
OSD-00002: additional error information
/S-error: (OS 5) Access is denied

The c:\ORACLE\diagdbms\protect path exists.

 

Cause

The service user(s) for the OracleOraDB12Home1TNSListener service and OracleServicePROTECT service do not have full permissions to the c:\ORACLE\diagdbms\protect directory on the database server.

Resolution

  1.  Add full permissions for the service user(s) to c:\ORACLE\diagdbms\protect.
    Note: Would recommend adding the user permissions to c:\ORACLE so the user has permissions to the entire path.
  2. After permissions are added, start the database:
    sqlplus /nolog
    conn sys as sysdba
    startup

  3. Once the database is running, confirm the protect listener is running.
    Open a command prompt on the database server and run: lsnrctl services

    Expected results:

    Services Summary...
    Service "protect" has 1 instance(s).
    Instance "protect", status READY, has 1 handler(s) for this service...
    Handler(s):
    "DEDICATED" established:0 refused:0 state:ready
    LOCAL SERVER
    The command completed successfully

  4. Confirm you can connect to the protect database
    sqlplus protect@protect

  5. Confirm the Symantec DLP services are running on the Enforce Server.

    The login page for the Enforce Console should now be available.

 

In another case, the 404 error was caused by a new network rule that blocked remote access to the Enforce console.
After correcting that network rule, remote access to the Enforce console was restored.