Unable to create ticket in ServiceNow
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Unable to create ticket in ServiceNow

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Article ID: 237196

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Updated On:

Products

Network Observability

Issue/Introduction

We have integrated Spectrum and ServiceNow but unable to create ticket in ServiceNow. We ae getting below error in stdout log.

Mar 02, 2022 01:55:18.846 - Error occurred while attempting to create a ticket in Service Desk. java.lang.Exception: {"Error":{"ErrorCode":130,"ErrorMessage":"Invalid Incident ID: 3b30fa2c1bce4594ba0b43f8ab4bcbc5","HTTPResponseCode":"NOT_FOUND","HTTPResponseCodeValue":404}}

 

Service Now : ROME

Spectrum Version : 21.2.1

 

Environment

Release : 21.2

Component : SPCINT

Spectrum Integrations

Cause

called id mandatory field is not mapped

Resolution

ServiceNow instance has Domains

When domains are present then caller id field is a mandatory field

Once Mapped caller id field with default value as the intergration user in Nim Mappings now tickets will create properly.

 

Save the mappings

Recycle tomcat service