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High Response time from Virtual Services in Performance VSE

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Article ID: 237156

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Updated On:

Products

Service Virtualization

Issue/Introduction

We have around 350 services running Performance VSE and recently PT team are executing the tests with 1000 TPS for data-driven virtual services. 

Another team are executing the test with less than 50 TPS which calls around 25+ services and getting a high response time of almost 1 mins which is causing the tests to fail with errors. 

We increased the disk space of the drives due to low disk space error. Even after increasing disk space the same response time is observed.

What could be the cause of such high response time?

 

Cause

Configuration changes needed for Performance VSE logging and for Data-driven test

Environment

All supported DevTest releases and platforms.

Resolution

Below is a recap of what resolved the issue.

1) fixed their vse_matches not rolling over which was killing their disk space on the performance VSE server.
Followed the below KB  https://knowledge.broadcom.com/external/article?articleId=7356

appender.VSEAPP.type = RollingFile appender.VSEAPP.name = VSEAPP #appender.VSEAPP.fileName = 
${sys:lisa.tmpdir}/vse_matches.log appender.VSEAPP.fileName = 
${sys:lisa.tmpdir}/${sys:VSELOGFIX}vse_matches.log #appender.VSEAPP.filePattern = 
${sys:lisa.tmpdir}/vse_matches.log.%i appender.VSEAPP.filePattern = 
${sys:lisa.tmpdir}/${sys:VSELOGFIX}vse_matches.log.%i
 
2) To deal with the data-driven virtual services we modified the local.properties using:
Refer to the section Performance Tuning of Data-Driven Virtual Services” in the documentation of the release of DevTest you are running.