Console hangs on message IEE156I K INVALID OPERAND -NONEAXC
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Console hangs on message IEE156I K INVALID OPERAND -NONEAXC

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Article ID: 237124

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Updated On:

Products

Automation Point

Issue/Introduction

AP MCS session console hangs on message IEE156I K INVALID OPERAND -NONEAXC. When this occurs, the only way to restart the console and clear the error is to pause the session, clear the command area, and then restart the session. This can result in automation being missed.

Example of a hung console:

Environment

Release : 11.7

Component : Automation Point

Cause

This issue is most likely caused by insufficient wait time being specified between two commands issued from the default MCS.SCR script file associated with the session definition. This in turn causes the two commands to become concatenated before they are issued resulting in an invalid command.

Here is the code section from the MCS.SCR script file causing the error:

Notice that when the two commands shown in red above are concatenated, this results in the invalid command "K A,NONEAXC HERE" being issued as shown in the earlier example, and that in turn causes the hang.  The one second wait time between the two commands is insufficient which causes the concatenation of the commands. 

Resolution

1. Open the AP Configuration Manager.

2. Expand the Automation tab:

 

3. Click on "Session Definition Sets" and then the "Configure" button:

 

4. Double click on the appropriate session definition entry under "Sessions" on the resulting page. The session definition will appear, click the "Customize Scripts" button:

 

5. Click the "Edit Script File" button:

 

6. Locate the "mcs.scr" entry in the list and click on it, then click "OK":

 

7. The mcs.scr file will open in a Notepad window for editing. Locate this section of the script code and increase the WAIT keyword value to two seconds as shown in red below (the comment can also be edited if desired):

*------------------------------------------------------------------------------*
* If the console didn't have a display area, the following error message       *
* will have been displayed in the console status line:                         *
*                                                                              *
* IEE151I DELETE REQUEST INCONSISTENT-NO DISPLAY ON SCREEN   ENTER    CANCEL   *
*                                                                              *
* Just in case that happened, send a PA2 using the mnemonic '@y'               *
*------------------------------------------------------------------------------*

  KEY=(@y)                 * (@y=PA2)
  WAIT=1                   * Wait 1 second for the command to be accepted
  KEY=(k a,none@E)         * Delete the area so we won't get more area displays
  WAIT=2                   * Wait 2 seconds for the command to be accepted

  KEY=(axc here@E)         * Tell CA OPS/MVS that AP is active at this console
  WAIT=1                   * Wait 1 second for the command to be accepted

ENDSEARCH                  * End of commands to perform if 'IEE152I' is found

 

8. Click "File" and then "Save" in the Notepad window. Close the Notepad the window.

9. Back out by clicking OK, OK, Close, and finally Exit.

The appropriate WAIT time has now been increased and should resolve the issue with the AP MCS console hang.

The newly edited MCS.SCR script file will be read the next time it is invoked with no further action necessary.

 

 

 

 

Additional Information

The AP WAIT keyword description:

https://techdocs.broadcom.com/us/en/ca-mainframe-software/automation/automation-point/11-7/command-and-keyword-reference/ca-automation-point-keywords/script-keyword-descriptions/wait-keyword.html