system is currently unavailable after creating a new IDM Connector for an SSL connection
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system is currently unavailable after creating a new IDM Connector for an SSL connection

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Article ID: 236854

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Updated On:

Products

CA Identity Portal

Issue/Introduction

After creating a second IDM connector, specifically for an SSL connection, once configured and set to be the Main connector the User interface no longer works and displays an error indicating "System is currently unavailable"

Environment

Release : 14.3

Component : IdentityMinder(Identity Manager)

Cause

This is being caused by the Managed Object Attributes being configured to use the original connector.   With debugging set for the Connector you will see an error indicating there is a backendName field which is not configured:


2022-03-14 09:43:55,680 ERROR [com.idmlogic.sigma.workers.utils.ExceptionsHelper] (default task-91) : com.idmlogic.sigma.errorhandling.exceptionObjects.NullFieldException: Field: [backendName] in entity of type: [com.idmlogic.sigma.entity.UserAttrEntity] with id: [63] cannot be null.

Opening the Portal Admin > Setup > Managed Object Attributes will show all the attributes with a "No backend names for this connector" message:

Resolution

There are 2 solutions:
1. Reset all Attributes to use the new connector; you will need to select the new Connector, then browse for and set the associated attributes, for instance the Portals UserID should map to the IDM attribute %User_ID%

2. A simpler solution is once you have verified the SSL connection with the test connector change the original connectors Protocol and Port to the SSL values.