Some client machines will display "Failed to update configuration" when trying to request new configuration
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Some client machines will display "Failed to update configuration" when trying to request new configuration

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Article ID: 236852

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Updated On:

Products

IT Management Suite

Issue/Introduction

After upgrading to a new ITMS version, the customer noticed that some client machines will display "Failed to update configuration":

Failed to update configuration
Error: The server is currently too busy to process the request (0x8004200C)

Environment

ITMS 8.x

Cause

Too many client machines were requesting configuration at the same time. We only allow 10 concurrent connections for requesting configuration at any given time. Any other client machine that comes after the SMP has already 10 client machines getting its configuration will need to wait until those threads are released.

Resolution

In this particular example, the customer rebooted this SMP server and the issue went away.

Other customers had tried to just restart IIS (open a command prompt as Administrator and run the "iisreset" command) and that helped him with the issue for a while.

Looking at the SMP logs you may see the following message around the time when these client machines were trying to get a new configuration:

Unable to process client request from: 10.7.15.63/HEAD/8.6.2198.0 (The maximum number of client policy requests has been reached ('MaxConcurrentConfigRequests'): 10, 0x8004200C)
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Date: 3/14/2022 7:56:10 AM, Tick Count: 319300515 (3.16:41:40.5150000), Size: 383 B
Process: w3wp (34132), Thread ID: 107, Module: w3wp.exe
Priority: 2, Source: GetClientPolicies

To prevent the possibility of having too many client machines requesting new configuration at the same time, try the following to reset their next interval:

Create a client-side task to Update Client Configuration using the following settings:

  1. Under the Jobs and Tasks section of the console right click on your desired location and select New> Task.
  2. On the Create New Task wizard, under the Notification Server section, select Update Client Configuration.
  3. Select "Update client configuration after a random period", set the Minimum delay to 1 and the Maximum to 10
  4. Make sure the "Randomize next configuration update time" option is selected.



  5. Click OK
  6. Schedule it for now to the "All Computers" filter (or any target that can cover most of your client machines)

Note 1:
In the past, some customers have tried to increase the default value for "MaxConcurrentConfigRequests" (under SMP Console>Settings>Notification Server>Core Settings>Active Settings) from 10 to something higher. That usually causes a bottleneck when there are now more client machines trying to get in for a new configuration. If your SMP server has enough resources for more connections, then you can try increasing this value in increments of 10 not never to exceed a new value of 50. A new value of 20 is usually a more reliable value to start with. 



NOTE 2: 
It has been seen where the value listed in the message (The maximum number of client policy requests has been reached ('MaxConcurrentConfigRequests'): 10, 0x8004200C)  does not accurately reflect the Core Setting value correctly after it has been changed.  Rebooting the Notification Server and restarting IIS didn't correct this.  Setting it back to the default and then to the needed value, if other than the default resolved it.