Password value in Policy Xpress
search cancel

Password value in Policy Xpress

book

Article ID: 236800

calendar_today

Updated On:

Products

CA Identity Suite

Issue/Introduction

When trying to reset Active Directory password using PX policy, the request fails with "Password does not meet installation minimum of 8 characters" error when a password value contains '^' symbol, like n0vA^xAnd3r?83

Environment

Release : 14.x

Component : CA Identity Manager

Cause

PX policy always treats '^' character in a string (not just password string) as a delimiter between multiple values, so this string n0vA^xAnd3r?83
is treated as 2 values: 'n0vA' and 'xAnd3r?83'

Resolution

This behavior is expected, and cannot be changed.

Password values that are to be processed by PX policies must not contain '^' characters.