NetOps Performance Management Portal web UI not responding
search cancel

NetOps Performance Management Portal web UI not responding

book

Article ID: 236567

calendar_today

Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

After a new install and making some changes with the SsoConfig command seeing errors in DX NetOps Performance Management (PM) Portal web server logs.

In the (default path shown) /opt/CA/PerformanceCenter/DM/logs/DMService.log we see these errors.

ERROR | pool-2-thread-1          | 2022-03-09 11:42:46,374 | com.ca.im.portal.api.services.datasource.DataSourcePoll          
      | Received WebServiceException from version check for data source EventManager@<PortalHost_FQHN>.  CAUSE=java.net.ConnectException: ConnectException invoking http://<PortalHost_FQHN>:8281/EventManager/DataSourceWS.asmx: Connection refused (Connection refused). MESSAGE=Could not send Message..  Returning DS_UNAVAILABLE result.
ERROR | pool-2-thread-1          | 2022-03-09 11:42:46,374 | com.ca.im.portal.api.services.datasource.DataSourcePoll          
      | javax.xml.ws.WebServiceException: Could not send Message.
ERROR | pool-2-thread-1          | 2022-03-09 11:42:46,374 | com.ca.im.portal.dm.productsync.DataSourcePoller                 
      | 
An error occurred during a sync request with data source EventManager@<PortalHost_FQHN>: additional info: enum.datasourceerror.DS_UNAVAILABLE.  The following stack trace shows the context of the sync request:
com.ca.im.portal.api.services.interfaces.datasource.DataSourceOp$Exception: enum.datasourceerror.DS_UNAVAILABLE
...
WARN  | pool-2-thread-1          | 2022-03-09 11:42:46,376 | com.ca.im.portal.api.services.sync.RegisterCacheCallbackRSImpl   
      | Invalidate cache callback failed, url=http://<PortalHost_FQHN>:8181/pc/center/webservice/invalcache, cacheName=DATA_SOURCE
org.apache.cxf.jaxrs.client.ClientWebApplicationException: org.apache.cxf.jaxrs.client.ClientWebApplicationException: org.apache.cxf.interceptor.Fault: Could not send Message.
...
Caused by: org.apache.cxf.jaxrs.client.ClientWebApplicationException: org.apache.cxf.interceptor.Fault: Could not send Message.
...
Caused by: org.apache.cxf.interceptor.Fault: Could not send Message.
...
Caused by: java.net.ConnectException: ConnectException invoking http://<PortalHost_FQHN>:8181/pc/center/webservice/invalcache/DATA_SOURCE: Connection refused (Connection refused)
...
Caused by: java.net.ConnectException: Connection refused (Connection refused)
...

ERROR | RIB/Engine               | 2022-03-09 15:07:13,171 | com.ca.im.rib.engine.sources.SourceScanner                       
      | Failed to scan RIB source
java.util.concurrent.ExecutionException: com.ca.im.rib.engine.sources.RIBSourceException: Unexpected error occurred while scanning a RIB source
  RIB Source URL: http://<PortalHost_FQHN>:8281/EventManager/EventManagerRibWS.asmx
...
Caused by: com.ca.im.rib.engine.sources.RIBSourceException: Unexpected error occurred while scanning a RIB source
  RIB Source URL: http://<PortalHost_FQHN>:8281/EventManager/EventManagerRibWS.asmx
...
Caused by: javax.xml.ws.WebServiceException: Could not send Message.
...
Caused by: java.net.ConnectException: ConnectException invoking http://<PortalHost_FQHN>:8281/EventManager/EventManagerRibWS.asmx: Connection refused (Connection refused)
...
Caused by: java.net.ConnectException: Connection refused (Connection refused)

Environment

All supported DX NetOps Performance Management releases

Cause

Web Service Host value override set against Local Override.

Resolution

The environment requires a specific host name be set for the Web Service Host. It was updated using SsoConfig in Performance Center Properties using the Local Override option.

When that value is set via Local Override it's not passed to other services (like Device Manager) or Data Sources for use. They instead use the incorrect local host value the system provides.

To resolve this set the Web Service Host using Remove Value and clear it from Local Override. This will result in being shared with other services or data sources. After a Global Synchronization passes and the value is sent to Device Manager the errors will no longer appear.

Steps to follow:

  1. Open a terminal to the Portal web server host.
  2. As the install owner run the command (default path):
    1. /opt/CA/PerformanceCenter/SsoConfig
  3. Enter 1. DX NetOps
  4. Enter 3. Performance Center
  5. Set the entry using Remote Value:
    1. Enter 1. Remote Value
    2. Enter 2. Web Service Host
    3. Enter u to update. Enter the correct host name. Confirm refreshed list shows new setting.
    4. Enter b to go back one menu.
  6. Clear the entry from Local Override:
    1. Enter 2. Local Override
    2. Enter 2. Web Service Host
    3. Enter r to reset the value and clear it out. Confirm the refreshed list shows the cleared out value.
  7. Enter q to quit back the terminal CLI prompt.

After making the changes restart the Device Manager and PC Console services. For additional service restart details see the How to properly restart the DX NetOps Performance Management environment Knowledge Base article.