Error: Could not resolve the next scheduled execution for event
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Error: Could not resolve the next scheduled execution for event

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Article ID: 23646

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Updated On:

Products

DSERIES- SERVER CA Workload Automation DE CA Workload Automation DE - Scheduler (dSeries) CA Workload Automation DE - Scheduler (dSeries)

Issue/Introduction

1) Events scheduled to run weekdays every <n> minutes do not resume after the weekend.

Example:

  1. Schedule: every 5 minutes weekdays
    Suspend at: 7:01pm
    Resume at: 3:00am
  2. Schedule: every 5 minutes except Saturday Sunday
    Suspend at: 7:01pm
    Resume at: 3:00am

2) Unable to upload a new Events to the Workload Automation Server. The upload fails with the following message:

Error: Failed to schedule the event <event_name>: Could not resolve the next scheduled execution for event. Check your schedule criteria.

Environment

CA Workload Automation DE 11.3.x, 12.x

Cause

This issue occurs if the schedule criteria is frequent enough to exceed the number of computed runs the DE Server can evaluate during the exception period.
In CA Workload Automation DE r11.1, the limit of computed run evaluations is 156.
In CA Workload Automation DE r11.3 or higher, the limit of computed run evaluations is 300.


In the example provided, the last run of the event would be at 7:00pm on Friday. After this, the DE server evaluates every 5 minute period from Friday at 7:05pm onwards until it finds one that matches the run criteria. The next matching schedule criteria would be Monday at 3:00am.

However, there are over 600 5-minute intervals between Friday 7:05pm and Monday 03:00am that the server would need to evaluate. When it reaches its limit of 156 or 300, depending on your version, it is no longer able to continue evaluating and the event does not get scheduled for the following Monday.


The same occurs when trying to upload a new Event where the Schedule criteria is frequent enough and the next valid start time is far enough into the future that the DE Server exceeds the limit number of schedule evaluations it can perform, resulting in the error message mentioned in the previous section and the Event not being created.
This is a known limitation of CA Workload Automation DE which causes frequently running events not to resume after the exception period.

Resolution

Instead of using the "except" and “weekdays” keywords in the freeform schedule criteria, you can add "Do not schedule" criteria for days where the Event should not run.
For example:
Schedule: every 15 minutes
Do not schedule: Saturday
Do not schedule: Sunday
Suspend at: 7:01pm Workdays
Resume at: 3:00am Workdays


Make sure you define the days of the week you considered as "workdays" under the SYSTEM calendar in the Services perspective on the Desktop Client.

Another suggestion is to add multiple schedules with 60 minute intervals.
For example:
Schedule: workdays at 07:00pm every 60 minutes
Schedule: workdays at 07:15pm every 60 minutes
Schedule: workdays at 07:30pm every 60 minutes
Schedule: workdays at 07:45pm every 60 minutes
Suspend at: 7:01pm workdays 
Resume at: 3:00am workdays

 
You are essentially creating 4 hourly Schedules, but together they will schedule the event every 15 minutes and none of the individual Schedules will exceed the stated limits when evaluating the next start time.

Additional Information

Troubleshooting