WA Agent upgrade fails with cybermation.iainstaller.library.CybFatalException
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WA Agent upgrade fails with cybermation.iainstaller.library.CybFatalException

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Article ID: 236386

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Updated On:

Products

CA Workload Automation AE - System Agent (AutoSys) CA Workload Automation DE - System Agent (dSeries) Workload Automation Agent CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation DE - Business Agents (dSeries)

Issue/Introduction

When upgrading the agent, users may see the following errors:

 

Custom Action:            cybermation.iainstaller.library.CybFatalException
Status: FATAL ERROR
Additional Notes: FATAL ERROR -     class cybermation.iainstaller.library.CybFatalException FatalInstallException: Input port is currently in use

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Custom Action: cybermation.iainstaller.library.upgrade.UpgradeCheck
Status: ERROR
Additional Notes: ERROR - class cybermation.iainstaller.library.upgrade.UpgradeCheck
NonfatalInstallException Upgrade check failed: com.ca.sysagt.utilities.AgentUtilsException: File busy!: /opt/CA/WorkloadAutomationAE/SystemAgent/WA_AGENT/cybspawn.bin

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Custom Action: cybermation.iainstaller.library.CybFatalException
Status: FATAL ERROR
Additional Notes: FATAL ERROR - class cybermation.iainstaller.library.CybFatalException
FatalInstallException: The agent is currently running or has jobs still executing. It cannot be upgraded.

 

Environment

Release : 12

Component : Workload Automation System Agent

Cause

Agent is still active or some other process is occupying the agent:

Input port is currently in use

The following error indicates, some job is still running.  The cybspawn utility will continue to run long running jobs after agent has been shutdown.

NonfatalInstallException Upgrade check failed: com.ca.sysagt.utilities.AgentUtilsException: File busy!: /opt/CA/WorkloadAutomationAE/SystemAgent/WA_AGENT/cybspawn.bin

 

Resolution

When upgrading the agent it is always recommended to stop the agent, because some agent files may be locked by OS.  If there are long running jobs, then jobs should be completed.

If the agent has been cleanly stopped and is not bound to port 7520 then OS (Linux /Windows) may not cleaned up the ports properly.  

 

Additional Information

This Red Hat KD, which describes that port may sometimes get stuck.  Rebooting of OS may be required for the ports to be released.