Add existing ITAM field to Service Desk
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Add existing ITAM field to Service Desk

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Article ID: 236366

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager CA Service Management - Asset Portfolio Management CA IT Asset Manager Asset Portfolio Management ASSET PORTFOLIO MGMT- SERVER

Issue/Introduction

We have a field Region in ITAM. Is there a way we can have this field displayed in Service Desk too?

Environment

Release : 17.3 or higher

Component : SDM - Customizations

Cause

Database fields that were defined outside of SDM cannot be added into SDM as SDM only supports new fields being introduced in WSP Schema Designer

Resolution

In this instance, the given location_id field from table ca_location is a field that was defined outside of the SDM Schema specification.  Examining the ddict.sch for table ca_location shows that this field is not natively present.  

SDM does not allow one to update its schema definition of ca_location, except through SDM WSP Schema Designer, and even then, the fields must be defined through the Schema Designer, disallowing externally defined fields such as the above field.