Network Discover detection server fails to start due to Remediation requests with error "Error occurred while creating pending remediation requests for item"
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Network Discover detection server fails to start due to Remediation requests with error "Error occurred while creating pending remediation requests for item"

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Article ID: 236354

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Updated On:

Products

Data Loss Prevention Data Loss Prevention Discover Suite Data Loss Prevention Core Package

Issue/Introduction

The Network Discover detection server is seen to be stuck in "Starting" state. 

On DLP 16.0.2 (RU2) and earlier, the detector status on Enforce will show that the process stuck in its startup is FileReader. Since DLP 16.1, FileReader does not exist as a standalone subprocess and instead, detector details will show the stuck startup for process DetectorServer. 

 

 

Cause

The startup stuck is caused by Discover Scan remediation requests which were left behind after the previous Discover Server service stop. Then during a subsequent startup, the server will attempt to process them before either FileReader (DLP 16.0.2 and earlier) or DetectorServer (16.1 and newer) can fully start.

The following error is logged within either Filereader or SymantecDLPDetectorServer0 logs:

 

com.symantec.discover.protect.remediator.PendingRemediationRequestManagerMethod: loadAndProcessPendingRemediationRequestsLevel: WARNINGMessage:  Error occured while creating pending remediation requests for item: //network-share/my file.docx and walk:4894com.symantec.dlp.remediation.async.request.RemediationRequestException: There is no scanAssignment for given Record at com.symantec.discover.protect.remediator.PendingRemediationRequestManager.fetchScanAssignmentFromDerby(PendingRemediationRequestManager.java:466) at com.symantec.discover.protect.remediator.PendingRemediationRequestManager.loadAndProcessPendingRemediationRequests(PendingRemediationRequestManager.java:173) at com.vontu.discover.DiscoverInductor.loadAndProcessPendingRemediationRequests(DiscoverInductor.java:451) at com.vontu.discover.DiscoverInductor.start(DiscoverInductor.java:256) at com.vontu.messaging.induction.InductorPool.start(InductorPool.java:172) at com.vontu.messaging.FileReader.start(FileReader.java:481) at com.vontu.messaging.FileReaderSetup.initialize(FileReaderSetup.java:110) at com.vontu.messaging.FileReader.main(FileReader.java:323)

Resolution

Follow the below steps to resolve this:

  1. From Enforce, ensure all scans targeted to this impacted detection server are in a stopped state. 
  2. Stop Symantec DLP Detection Server (16.0 RU2 or older) or Symantec DLP Detector Server (16.1 and newer) service on that impacted server. 
  3. On same server go to folder \ProgramData\Symantec\DataLossPrevention\DetectionServer\<dlp version>\scan\catalog (this is the default path but will vary depending on where DLP is installed). 
  4. Take a backup of the RemediationResiliencyStorage folder (copy entire folder in a backup folder outside of where DLP is installed). 
  5. Delete the RemediationResiliencyStorage folder from the 'catalog' parent folder.
  6. Then start the DLP server service on the detector back up. 
  7. If the detector still does not complete startup in full, repeat steps 2 and 3 and delete everything inside the catalog folder & incremental_index folder (take a backup of both folders before you do this). Then again try restarting the detector service.