When the su command is called, PAMSC will maintain the user's original identification when determining to allow access to a command or file or performing certain PAMSC functions. A PAMSC user must be an administrator in order to run the sebuildla utility, so it will fail if the original user is not an administrator. This can be confirmed by running the sewhoami -a command and looking at what is listed for User's Mode.
[root@ExampleServer ~]# sewhoami -a
exampleuser
ACEE Contents
User's Name : exampleuser
ACEE's Handle : 11
Group Connections Table:
<Empty>
Categories : <None>
Profile Group : <None>
Security Label : <None>
User's Audit Mode : Failure LoginSuccess LoginFailure
User's Security Level : 0
Source Terminal : 10.#.#.#
Process Count for ACEE : 4
User's Mode : Regular
Log into the PAMSC server with a current PAMSC administrator and run the sebuildla -a to rebuild the lookaside database.
In order to allow exampleuser to run the sebuildla in the future, add the administrator attribute in PAMSC by following these steps:
The change will not take effect if exampleuser is logged in when the eu command is run, it will take effect on the next login. To confirm, run sewhomi -a on the next login.
[root@ExampleServer ~]# sewhoami -a
exampleuser
ACEE Contents
User's Name : exampleuser
ACEE's Handle : 11
Group Connections Table:
<Empty>
Categories : <None>
Profile Group : <None>
Security Label : <None>
User's Audit Mode : Failure LoginSuccess LoginFailure
User's Security Level : 0
Source Terminal : 10.#.#.#
Process Count for ACEE : 4
User's Mode : Administrator