Unable to login as admin to /immanage , Management Console after Upgrade to 14.4 vapp
search cancel

Unable to login as admin to /immanage , Management Console after Upgrade to 14.4 vapp

book

Article ID: 236054

calendar_today

Updated On:

Products

CA Identity Manager

Issue/Introduction

After upgrading from vAPP 14.2 CP5 to 14.4, logging in to the IDM management console no longer works. The login prompt keeps returning even though you are logging in with the correct user/password pair.

 

Environment

Release : 14.4

Component : CA IDENTITY SUITE (VIRTUAL APPLIANCE)

Cause

There is a missing row in one of the object store tables, IM_MOBJ_DEF_LD. You have already verified that the admin use exists in the auth tables.

Resolution

set IDENTITY_INSERT IM_MOBJ_DEF_LD ON


  insert into IM_MOBJ_DEF_LD (UNIQUE_NAME,REF_ID,SECTION_NAME,ATTRIBUTE_NAME,ATTRIBUTE_VALUE) values(<new_value>,6,'TABLES','PRIMARY','IM_AUTH_USER')


set IDENTITY_INSERT IM_MOBJ_DEF_LD  OFF

Note: <new_value> should be last UNIQUE_NAME of the table +1

 

For example,

 insert into IM_MOBJ_DEF_LD (UNIQUE_NAME,REF_ID,SECTION_NAME,ATTRIBUTE_NAME,ATTRIBUTE_VALUE) values(73162,6,'TABLES','PRIMARY','IM_AUTH_USER')