Migrated running processes are not moving forward after upgrade
search cancel

Migrated running processes are not moving forward after upgrade

book

Article ID: 236003

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

We upgraded Clarity from 15.6.1 to 16.0.1 and the pre-upgrade processes on the system are not moving forward. They are not being loaded on the process engine either. Any new process created after the upgrade works OK.

Environment

Clarity 16.1.2

Cause

The process engine does not recognise the processes at DB side as per the hostname change action which typically results during a DB refresh (prod to non-prod)

Resolution

Steps to resolve/workaround the issue:

  1. Stop the Clarity services
  2. Run the following update to the DB:
            update bpm_run_processes
                set process_engine_id = xxxxxxx,
                      last_process_engine_id = xxxxxx
            where process_engine_id = yyyyyyy
            and last_process_engine_id = yyyyyyy
      
    Note: xxxx will refer to the current process engine id on the bpm_run_process_engines table
  3. Restart the Clarity services

Additional Information

SQL query to differentiate process engine ids for the processes that are in running state:

select process_engine_id, count (*) from bpm_run_processes where status_code='BPM PIS RUNNING' group by process_engine_id