Check Database on the Task Persistence Monitor page in the IM User Console generates a null error
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Check Database on the Task Persistence Monitor page in the IM User Console generates a null error

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Article ID: 235815

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Updated On:

Products

CA Identity Manager CA Identity Suite

Issue/Introduction

Clicking the Check Database on the Task Persistence Monitor page in the IM User Console generates a null error and the IM Server log shows the following:

ERROR [ims.ui] (default task-2) com.netegrity.webapp.page.TaskController: java.lang.NumberFormatException: null
 at java.lang.Integer.parseInt(Integer.java:542) [rt.jar:1.8.0_231]
 at java.lang.Integer.parseInt(Integer.java:615) [rt.jar:1.8.0_231]
 at com.netegrity.webapp.page.task.TaskPersistenceMonitorTab.update(TaskPersistenceMonitorTab.java:272) [user_console.jar:]

Cause

The IM application will perform the below sql commands and if they do not complete successfully then IM will have an error:

ANALYZE TABLE TASKSESSION12_5 COMPUTE STATISTICS

ANALYZE TABLE EVENT12_5 COMPUTE STATISTICS

ANALYZE TABLE EVENT_OBJECT12_5 COMPUTE STATISTICS

select blocks, empty_blocks,avg_space, num_freelist_blocks from user_tables where table_name = 'TASKSESSION12_5'

select blocks, empty_blocks,avg_space, num_freelist_blocks from user_tables where table_name = 'EVENT12_5'

select blocks, empty_blocks,avg_space, num_freelist_blocks from user_tables where table_name = 'EVENT_OBJECT12_5'

Resolution

Verify the above mentioned sql commands are returning successfully by connecting to the same task persistence database that the IM application is using. If there are errors in running the sql commands then work with your DBA to resolve those errors.