Error "WebApi Controller failure" when attempting to upload package files with extension .exe into the Software Catalog
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Error "WebApi Controller failure" when attempting to upload package files with extension .exe into the Software Catalog

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Article ID: 235809

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Updated On:

Products

Client Management Suite IT Management Suite Software Management Solution

Issue/Introduction

When trying to add files of a package into the Software Catalog, all file types would add with the exception of .exe files and the SMP Console displayed the following message:

An error has occurred during uploading files to server.  Check server logs for details.

The messages seen in the Log Viewer on the SMP are:

WebApi Controller failure.

The process cannot access the file '\\<NSserver>\SoftwareLibrary\3344e566-d700-4ea1-9eac-a3ed20e559e7\application.exe' because it is being used by another process.

 

Environment

ITMS 8.6.x

Cause

Crowdstrike 6.33.14705 was installed. This issue has also been reported with MsSense.exe, a component of Microsoft Endpoint Detection and Response. 

Resolution

Uninstalling Crowdstrike and other offending AV including MS EDR, or placing Crowdstrike in monitoring mode resolved this issue.

NOTE: Was not able to disable Crowdstrike so it was uninstalled from the Notification Server.  Also, the Crowdstrike logs didn't contain any information that helped troubleshoot this particular issue.

As a Workaround if it's possible to ZIP the package executable, and then import it - as once you upload the package - you will be prompted to extract the content and if you confirm extraction it would be able to save executable without CrowdStrike blocking the content.