Unable to upgrade Workflow 8.6 RU1 to Workflow 8.6 RU2 release because WF 8.6 RU2 installer crashes
search cancel

Unable to upgrade Workflow 8.6 RU1 to Workflow 8.6 RU2 release because WF 8.6 RU2 installer crashes

book

Article ID: 235613

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

During the upgrade of the WorkFlow (WF) Server from 8.6 RU1 to 8.6 RU2, the Installer crashes at step "System Accounts Access" in the Symantec.Workflow.Installer.exe

In Windows Event Logs following events are logged:

 

Steps to duplicate:

1. Installed all features one by one which have been installed (Very strange that there is DNS, AD features installed on this server, where there is SMP, SQL, and Workflow 8.6 RU1 installed)
2. Installed SMP 8.6 RU1, CMDB Solution 8.6 RU1, Workflow 8.6 RU1, and Service Desk 8.6
For Workflow 8.6 RU1 installation, I used windows credentials (currently logged in domain admin account which is also local admin "domain\admin".
Same domain admin account used for SQL Server connection (I manually added it in SQL logins) to access ProcessManager database
In WF 8.6 RU1 installer on the accounts page, I added "corp\myadmin" 

Workflow 8.6 RU1 installation successfully completed as well as Service Desk 8.6 installation.

3. Downloaded workflow 8.6 RU2 installer and then it crashes on accounts step

Environment

ITMS 8.6 RU1 upgrading to 8.6 RU2

OS Win Server 2016. Installation with service domain account (local admin)

SMP server and SQL server on same box.

Cause

Known issue. We simplified usage of IIS Web Manager API.

Resolution

A fix is already included in our ITMS 8.6 RU3 release.

Additional Information

NOTE: One user was unable to get this to work so they set the "Symantec Workflow Server" to "Manual" start as they are not using Workflow Solution.