High CPU usage on vAPP 14.3 CP3 servers
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High CPU usage on vAPP 14.3 CP3 servers

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Article ID: 235563

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Updated On:

Products

CA Identity Suite

Issue/Introduction

Whenever we submit the bulk load tasks CPU usage is showing more than 200% then after a few mins it is getting reduced to less than 100%.

There is no impact but we are having the monitoring alerts in place we will get the alerts.

Could you please provide a solution for high CPU usage issue?

 

Environment

Release : 14.3

Component : IdentityMinder(Identity Manager)

Cause

The CPUs will allocate resources as required and usage can go very high during high load activity like bulk loads, for example. 

As long as the CPU usage recovers, this is normal behavior.

Resolution

There are no additional patches required for RNG or high CPU on 14.3 as CP3 is the latest cumulative patch.

IN 14.3 CP3 the RNG has been replaced and is no longer being used.

Also, you can verify that you no longer are receiving the below messages on your vAPP servers during the health check. As long as you do not receive these messages you are up-to-date with CPU consumption fixes.

[WARN] Cannot check the heap size for Identity Governance - jstat command ("/opt/CA/jdk1.8.0_71/bin/jstat") returned error 1 for PID 6732
[WARN] Cannot check the heap size for Identity Manager - jstat command ("/opt/CA/jdk1.8.0_71/bin/jstat") returned error 1 for PID 94045
[WARN] Cannot check the heap size for Identity Portal - jstat command ("/opt/CA/jdk1.8.0_71/bin/jstat") returned error 1 for PID 15501

Customer Detected :    RNGD process running and consuming high CPU