BG Stops sending emails after disruption in email server connectivity
search cancel

BG Stops sending emails after disruption in email server connectivity

book

Article ID: 235542

calendar_today

Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

BG never sends an email from process  If there is disruption in connectivity in the email server from clarity server running BG services until the BG services are restarted 

STEPS TO REPRODUCE: 

  1. Login to Clarity and create a process to send emails every 5 minute or so 
  2. On the email server shut down the email server services for 2 minutes 
  3. Check back the clarity process and it should be working and email are not send particularly from BG services where as any notification sent from clarity app services work 

Expected Results: Once the email service is restored clarity BG services should be able to send email 

Actual Results: Once the email service is restored clarity BG services work fine but no emails are sent

Environment

Release : 15.9.2, 15.9.3, 16.0, 16.0.1 

Component : CLARITY COLLABORATION (DOC & ACTION ITEMS)

Cause

DE64199 

Workaround: Till the defect is fixed please restart the BG services. 

 

Resolution

Resolved in 16.0.2

Once the fix is implemented you can expect: 

  • Clarity will have debug logs on mail message class which can help to find out if there was email connectivity issue 
  • BG Service will try to deliver email once the email server connectivity is restored.
  • The emails which went out during the email service connectivity issue, those emails Clarity service will not have any retry mechanism to send the email