How to Restart LDAP Agents
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How to Restart LDAP Agents

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Article ID: 235504

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Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

When troubleshooting LDAP issues, it may be necessary to try restarting the LDAP agents.

Per https://techdocs.broadcom.com/us/en/ca-enterprise-software/business-management/ca-service-management/17-3/administering/configure-ca-service-desk-manager/managing-servers/how-to-start-the-ca-sdm-servers.html

LDAP Communication is controlled by:

LDAP virtdb (ldap_virtdb) - Agent for communication with LDAP Servers

Environment

Release : 17.x

Component : SDM - Authentication/LDAP/AD/EEM

Cause

It may be necessary to restart ldap_virtdb when seeing various LDAP issues

Resolution

To Restart the LDAP agents you can:

1) End the ldap_virtdb task in Task Manager:

2) You can obtain the PID of ldap_virtdb.exe from Task Manager or by running pdm_status and killing the PID in a command prompt

  1. Obtain the PID from Task Manager or opening Command Prompt and running pdm_status
  2. Open Command Prompt if not already open
  3. Type pdm_kill <pid>

Additional Information

pdm_ldap_test is a good command for testing the ldap connection

You can verify the process restarted by checking the timestamp of ldap_virtdb in pdm_status