Some users can't see Groups or Inventory menus in OC despite having access in their ACL
search cancel

Some users can't see Groups or Inventory menus in OC despite having access in their ACL

book

Article ID: 235464

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM) Unified Infrastructure Management for Mainframe

Issue/Introduction

After upgrade from UIM version 20.3.3 to 20.4 some users no longer have one of the Operator Console OC menus (e.g. "Groups", "Inventory") visible in the tabs on the left side.

In the ACL, the "OC Menus" tab has the correct options selected but still the users cannot see these menus.

Environment

Release : 20.4

Cause

- This is related to leftover data from the old USM portlet.

Resolution

This is resolved by applying the OC CU2 patch for 20.4.

If you have not yet applied CU2, you may execute the following query against the UIM backend database to resolve this issue:

delete from umpHiddenViews where groupName like 'USM%';

It is not necessary to restart anything; after running this query, the affected users should log out of OC and then log back in.